Frequent failures in both HomeKit and Mysa app

I’ve got seven baseboard thermostats (v1). For quite a while they worked well, but now I’m experiencing frequent (nearly constant) failures with them: - HomeKit generally shows them as “updating” for a long time before showing “not responding”. - The Mysa app can read their current status but can’t change the setpoint. Rebooting the thermostats helps for a short time (ranging from minutes to hours). Rebooting the router has no effect. I have dozens of other HomeKit devices — outlets, switches, locks, most wifi, several Bluetooth — working reliably throughout the house. Given that these are about $900 worth of thermostats, which is a pointless expenditure if they don’t reliably update according to scenes and automations, it’s pretty important to me to get this fixed. As an aside, a support forum that doesn’t let you log in if cross-site tracking isn’t enabled is kind of problematic.

Didn't find what you were looking for?

New post
Was this post helpful?
4 out of 4 found this helpful



  • A couple of things to note: The last HomeKit update DID interfere with a number of IoT devices and Mysa's products were affected. I would advise you to re-pair the devices and reinstall the Mysa app - we cannot push out firmware directly from HomeKit and that may solve the issue. However, if you're still having issues contact us at and someone will help you out :)

  • When was this last update? I re-paired five of the seven thermostats a month ago, without any improvement.

    And what’s the latest firmware version? It looks like I’m running 2.8.1.

  • I'm having the same issue as lackey and reported it December 6th. I received a quick response that it had been forwarded, but no other communication since then.

    Scenario is similar with 7 V1 Mysas. I also have other Homekit devices such as outlets and lights working without a problem. The thermostats seem to attach and re-attach to Homekit, with some not coming back at all. I can get them back temporarily when I do a soft reset on the thermostat. 

    I have access to the thermostats via the Mysa app. As a test, I added them to Alexa which can also reach all of them. I just checked Homekit and none of the 7 are responding, but Alexa and Mysa can.

    I checked the firmware and it's also at 2.8.1.

    It's a bit frustrating that no notifications are coming from HomeKit to indicate they're not responding; typically I have to select a Scene and wait for it to fail to see which ones have disconnected. There is also no logging for troubleshooting.

    I haven't re-paired them. If that's the recommend solution, then please be specific about where and how they should be re-paired. Should all of them be deleted, including the app, first and then re-added? If there is a concern about a setting or configuration, I want to make sure I'm doing it correctly so there is no residual info.

    I was going to tell you about my network, but the fact that they can be reached via Mysa and Alexa kind of makes that point mute.

    Also, I agree with lackey about the cross-site tracking.


  • This is what I got from Support overnight:

    I am very sorry, at this time I do not have any specific additional updates.

    There does appear to be this issue with a random number of users - the software team has been trying to work with Apple further to determine the root cause of this.
    However, this does look to be a common thread among Apple HomeKit ranging across a number of different devices.
    For now the best troubleshooting tips would be to try:
    1. Rebooting your router when this may occur.
    2. Verify that you are using a common or public DNS such as the Google DNS.

    I went in and changed the DNS as per the recommendation. I then also rebooted my router and two WiFi APs, and all my thermostats reattached to HomeKit without me having to reset them. I'll keep an eye on them and see if this lasts.

    On a related topic, do either of you know if the Mysas check HomeKit for what their current state should be? I noticed one of them was at a different temperature than what I have programmed for that time of day. The reason for asking, is observed one of my outdoor plugs needed to be manually reset after the reboots and it did appear to check its current state and automatically turned on. Logically to me, it seems to make sense that they would check what state they should be after a disconnect. Let me know if I've got this wrong.

    Another thought on the state checking, is that in my case I have the Mysa app, as well as the Mysas connected to Alexa. Is there a default location that the Mysa check their state?



  • That didn't last long, with 4 out of 7 not responding. Used Alexa to set the temperature.

    Not sure why the advice was to change to Google DNS. I've heard that Google is faster, but I've never noticed resolution being an issue with any other device.

    Suggestions? I have not yet deleted and re-added the Mysas as that is a pain, especially if I have to recreate all my automations. Bradley let me know if that is an actual known fix or just a stab in the dark.


  • Similar problems with no response popping up on HomeKit. Reset fixes for a few hrs but then it’s back. And it still works ok with the Mysa app (I don’t have Alexa). However I can add that I have 2 V2 and 1 V1 baseboard Mysas and the problem is only with the V1 unit. Once I finally got the V2 units connected they’ve been stable. 

    I’ll follow this as it would be nice to get the V1 fully functional again as HomeKit compatibility is Mysa’s big selling point and the only reason I chose them over a cheaper thermostat. If anyone has found or been given a solution I’d like to know it, otherwise this is more money wasted (and yes I ultimately blame Apple which has really fallen very far from the it just works days).

  • Thanks Michael for sharing your experience with V2. I agree with you about Homekit, it just doesn't work well.

    Last night my automation failed and a little while later when I checked, all 7 of my devices were there and executed when I selected a Scene. Just checked and I have 5 devices that aren't responding. Ran a test with Alexa on two Mysas and got the current temperature. I then got Alexa to change the temperature in the room I'm in and it did it without a problem. Rechecked Homekit and it still says the 5 thermostats are not responding.

    I did some further reading and found this on Mac Rumors:

    With Google and Alexa, as long as each device can see the Cloud, things work because everything goes to the cloud and back. With HomeKit, devices and hubs need to see each other because of the above - and if you have a network that isolates devices (prevents them from talking to one another or blocks protocols like mDNS/Bonjour) or treats WiFi and Ethernet as different networks, you end up with No Response errors and other problems.

    My network is flat. I have a Telus Router with two Telus Boosters which are backhauled using ethernet to the router. I have a single SSID and there is no isolation that I've put in. Interesting to note that both Alexa and Google rely on the devices connecting back to their cloud, which must be happening with the Mysas.

    I wonder if this is related to the Home Hub. From what I've read, the Home Hub is only required for external access, but I'm assuming it must be used for automations while away.  I checked and I have 4 Home Hubs, with two of them being HomePod minis, an iPad, and an Apple TV; the connected one was the Apple TV. I reset the Apple TV and it automatically shifted the Hub to one of the HomePod minis and I lost connectivity to all 7 Mysas; before the reset, 2 of the 7 Mysas were responding. I then did a reset of my APs and all 7 Mysas are now reachable. I may play around with the Home Hubs, perhaps limit it to 1, to see if it makes a difference. 

  • The V2s continue to stay connected without issue. Wonder what’s different. No word from Mysa. 

  • I thought I might be onto something with setting the Home Hub to my HomePod minis, but it didn't help.

    I just did a reset of my two wired APs and at first Homekit seemed to show all 7 were online, then a few minutes later 3 dropped off, and then just a moment later two reconnected and all of them showed connected. Tried to run a scene and it failed, so I reset the Home app on my iPhone and now it's showing all 7 are offline. It seems to be floating between being online and offline. Meanwhile, they continue to be accessible through Alexa and the Mysa app.

    The key thing about this is that the Mysas are definitely connected to the network. I again rain through a series tests using Alexa and could see the Mysa changing temperature. Using Siri/Homekit gave me a response that the thermostat is not responding.

    I'm out of ideas. I'll ask about the V2.


  • Hello - I'm with Mysa. I've been watching the discourse here and have to say thanks for trying out different things. I've noted all the responses and have passed them on to our testing group to see if anything was helpful. Homekit issues have admittedly been something affecting numerous users for a couple of months and we've placed a priority on getting it fixed. Any set-up and troubleshooting you've done (like you've documented here) will help our team solve this issue and we're hoping that we will have answers sooner rather than later. Just know that we are working diligently on this!

  • Gerry’s “on again/off again” behavior is very much like my own experience, the main difference being that mine are also often not controllable with the Mysa app. It’ll read their current settings, so there must be a good network connection, but it won’t change them.

  • Mysa did respond to my request with detailed instructions for pairing. They were the same as I’d been following with the additional step of disabling home data in setup under Mysa before starting. Unfortunately it made no difference and the V1 became unresponsive with HomeKit as before within 2 hrs. They also said they were escalating the case. 

  • Hello, I have the same issue with Homekit. I have 4 mysa v1 with firmware 2.8.1.

    I noticed that when I wake up, the Mysa often works in Homekit. However, this doesn't last and they soon all show no response. They seem to always work in google home and the Mysa app.

    I tried a complete reset, removing from homekit and mysa. This didn't change anything. Actually, when adding the thermostat to homekit, the thermostat is found by homekit and once added it shows no response.

    Hoping to see a resolution soon as all my home automation is broken because of this.


  • Here are some further observations:

    Today I did a power reset on all my thermostats and almost immediately most of them returned, except for one which took a while. I was just on my iPhone about 5 minutes ago and could see them all, then my phone locked and when I went back in they were all not responding. Five minutes laters, they were all back.

    Yesterday, I had trouble accessing them through Alexa, but it worked through the Mysa app. I told Alexa a couple of times to adjust the temperature in my room, but didn't see a change. I then switched to the Mysa app and even it took a few moments, and a couple of temperature changes, to see the display update. I know some of my Homekit automations worked, as my geolocation routine flipped some of them off when I left the house, but didn't turn them back on.

    Another observation, I have the V1, with model numbers BB-V1-0, V1-1, and V1. They are all running the same 2.8.1 version of firmware. When I do a software reset by pressing the down arrow key, I've noticed some of them react differently with some a smooth and quick countdown to 0, while others can be jerky and take a bit "jerky" on the way down; the point I'm making is that they don't appear to operate the same way considering they're all running the same version of firmware.

    I've been dealing mostly with Tanner in support and he sent this recently "We have noticed that the V1 Mysa does show this behaviour in a different way than the updated V2. The V2 will reset more often to reconnect throughout the day where the V1 may not." BTW, I've dealt with Tanner before and he's been really good interacting with me.

    Thinking back, the connectivity to the Mysas hasn't been the most stable; I've had to do resets before and even re-add them. If it happened in the spring or fall, it probably took me a bit longer to notice... a major gripe of mind is that I don't know when these devices go offline until I go look at them. Stable connectivity has been an issue for a while, but it's gotten much worse now.

    Oh, just went into my iPone and my seven Mysas and not responding. That was about 15 minutes from the last time I checked.

    Hopefully more information is better... I have Philips HUE, Lutron, iHome outdoor plug, Meross outdoor plug, Wemo plugs, HomePod Minis, and Apple TV. The Philips and Lutron have their own bridge and are wired in, while the others are WiFi. I have no issues with any of them being unresponsive.

    Just out of curiosity, will the Mysas be upgradable to support Thread and Matter, which are the new Smart Home standards being introduced later this year? Maybe this situation goes away when they do... or perhaps gets worse. ;-) 

    Let me know if you need further info.

  • IIRC, thread requires a different radio, doesn’t it? So my guess is that the V1 can’t support it (neither can the original HomePod, though the mini can).

  • @lackey, I haven't heard anything about the radios, but suspect you might be correct as they would need to be able to transmit. From what I've been reading, you're also correct about the HomePod minis being able to support Matter as well as Amazon Echos. It'll be interesting to see if any existing devices will be able to support Thread or if they will need to be replaced.

  • I’m having the exact same problem. I actually just came here looking for a solution.
    I have 2 V2’s and 1 V1 for baseboard. The V2’s have been pretty stable. But the V1 is always offline. I’m on the latest FW.
    My problem isn’t only with homekit tho. I can’t get the mysa app to see the V1 most of the time either.
    Luckily I only have 1 V1, so if it’s a hardware issue I’ll just replace it with a V2.
    Maybe if ya’ll can’t get it figure out you should offer a trade up program?

  • I haven't heard anything from Mysa about this issue and saw someone else posting a similar issue. Any updates?

    I continue to have issues where the thermostats are sometimes connected, but typically there is either one or all of them in an "Updating" state.

    I have them connected to Alexa and it too is proving to be unreliable, albeit a bit more reliable than Homekit.

    I can almost always access the thermostats through the native Mysa app, but I have found a couple of times that I have to go into the app twice for it to register a change to a thermostat.

  • I had the exact same problem. Just found the solution by activating UPNP in my router settings.

  • Sadly, my router already had UPNP enabled, so no dice.

    Like Gerry Schenk, I’m finding that it’s pretty consistent that I need to change a set point twice in the Mysa app before the change will take.

    It’d be great if we could get some regular updates on the progress to solve this problems. I’m starting to feel like I’d be better off with my old dumb thermostats.

  • I just had a look at the firmware of my thermostats and they appear to be on version for roughly half of them, which seems to be a number of revisions from the 2.8.1 we had when we started this discussion. These are the current models and firmware versions I have:

    • BB-V1-0 with
    • BB-V1-0 with 2.8.1
    • V1-1 with 2.8.1
    • BB-V1-0 with
    • BB-V1-0 with 2.8.1
    • BB-V1-0 with
    • V1 with

    I had a look on Mysa's website and there are notes regarding the firmware; it's still referencing 2.8.1. Not sure if this is a rollout and the ones which aren't updated are pending.

    I've been at this since December 6th and still no solution. Mysa, any updates as to what is going on with

  • 6x BB-V1-0 with

    1x v1-1 with

    None are responding in HomeKit. 

  • I am another customer with a very large base of devices (investment) and am experiencing the frequent disconnects to HomeKit.

    In my case, the devices can be reset and they show up in HomeKit and respond for a little while, but then eventually drop off after an hour or so.

    Once dropped they never return to HomeKit on their own until they are reset.

    In the mysa App ... Once the drop described above occurs, they do not respond to the mysa App on the first try, but will eventual respond to the mysa App if I change settings a couple of times. 

    Very frustrating to have spent all of this money and not have a stable automation control.

    Perhaps as an interim workaround, the mysa folks should open up the API and allow for other / crowdsourced home automations to be able to communicate and control these things. My other thermostat integrations are flawless from numerous home automation integrations.

    The lack of stable communications from the limited automation control options available and the lack of a robust open API is definitely having me consider other options. This is a shame, as I like the hardware aspects of these devices, the software automation on the hand is very questionable and the poor response and non open API options is simply unacceptable in todays world. If you can't fix the issue, then at least open the API up to the public so others can!


  • Lack of action from Mysa makes me think this is not a simple problem to solve. I’m glad I didn’t invest a lot in V1 units, and won’t likely buy anymore than the 2 v2 I have. I’d look at other options but the reason I went w Mysa originally was because they were the ONLY HomeKit option for line voltage baseboard.

    The v2s function pretty well so far but still both reset themselves several times daily. Meanwhile the Ecobee I’ve had for many years for my AC unit continues to perform flawlessly making me wonder what the difference is.

  • There are a number of ways to get to HomeKit from other automation ecosystems if you can first get to the devices via the API. As an example if we could access the mysa devices directly, the plugins could bridge to the HomeKit integrations. Here are two (HomeBridge / IndigoDomotics HomeKit Bridge Plugins) that I use frequently with great success from a variety of devices (including other thermostats, SPA controls and weather stations).

    The problem is mysa needs to open their API to allow other ecosystems to access the devices. Once opened via API the communities from other automaton solutions have great ingenuity and have already figured out how to play with HomeKit (without issue) along with the robust solutions in their own respective platforms.

    The roadblock here is that mysa does not seem interested in providing the API access which stifles all of the potential progress from other solution providers.

    Seems like a double whammy in that mysa cannot seem to correct their integration issue and support the direct HomeKit integration properly, and they will not allow direct access to the devices via the API's for other communities that can already play with HomeKit just fine.

  • Hey! From Mysa again. I have messaged here before and I just wanted to update with as much transparency as I can at this point. I'm our marketing communications person, not a developer, so I'm just relaying what I understand after some internal discussions. 

    First, an update on Homekit errors. Every day we're picking away at a solution to this. We're fairly confident we know what is happening, but finding a lasting solution is difficult because of some specifics when it comes to both hardware and limitations within the Homekit ecosystem. Our team has been working with Homekit basically since we've launched and there have been changes on both sides since then. As all of this discourse points to, it seems as though our BB2 models are much more unlikely to have Homekit issues. The older models (BB1.0 and BB1.1) seem to be the ones having the most trouble and there are certain connectivity iterations that exacerbate the problem. Some things that help some set-ups make others worse and vice versa. 

    Second, we've had an open API on our roadmap for a long time and the end goal hasn't changed. The timeframe, however, has. This year is dedicated to stabilization in some key areas and we're focusing on making our products and app more intuitive first and foremost. Opening up our API, from my understanding, has its own challenges. So - with full transparency - I do not have an estimated date for an open API but can safely say that it is still in the plans, albeit not right away. 

    So where does that leave us? Well, I wish I had more concrete answers. Our team IS hard at work at this, and I've had many discussions about the nuances of the problem. What I can do is offer you a place in our newly revamped testers groups. We will be dealing with a number of issues and testing fixes and new features. This will also give you a more direct line to our development team and can help enact lasting changes in the product that you want to see. 

    If anyone wants to sign up, email with subject header "beta testing" and I will send you a sign-up link. You'll fill out a questionnaire and the product and development teams will help you from there. 

    We're not ignoring this dialogue! In fact, it has been quite helpful. The next step is to put this to action and help make Mysa a product that works for everyone. 


  • Hi there, I do have the same issues as others with my Mysa thermostats and Homekit. This breaks my automation. Thanks for the update Brad, I look forward to beta test the changes and the open API.

    I also want to share that I created a workaround using HomeAssistant and the Google Assistant integration. It is far from perfect and does not work sometimes, but it does most of the time. What I did is create helpers in HomeAssistant that get triggers when I want to change the temperature on the Mysa. I then use the Google Assistant integration to send the commands to Mysa.

    As I said, this is not perfect, but as enabled me to still use the automation to set the temperature on my Mysa.

    Of course, having an integration with HA would be best.


  • As of yesterday, my thermostats appear to be responding again — all seven, and quickly. They’ve updated to It’s a bit early to know if this is a reliable change, but it’s a good sign.

  • Nice to see that updated firmware with potential is available.

    What is the process to get the updated version? Mine are all still all 2.8.1. 

    How can get mine to update?

  • This is the user formerly known as “lackey”.

    I’m continuing to see improved, but not ideal, responsiveness with One thermostat stopped responding Saturday night, and two more last night. All three began responding after a restart. When they are responding, all seven respond very promptly.


Please sign in to leave a comment.