Frequent failures in both HomeKit and Mysa app

I’ve got seven baseboard thermostats (v1). For quite a while they worked well, but now I’m experiencing frequent (nearly constant) failures with them: - HomeKit generally shows them as “updating” for a long time before showing “not responding”. - The Mysa app can read their current status but can’t change the setpoint. Rebooting the thermostats helps for a short time (ranging from minutes to hours). Rebooting the router has no effect. I have dozens of other HomeKit devices — outlets, switches, locks, most wifi, several Bluetooth — working reliably throughout the house. Given that these are about $900 worth of thermostats, which is a pointless expenditure if they don’t reliably update according to scenes and automations, it’s pretty important to me to get this fixed. As an aside, a support forum that doesn’t let you log in if cross-site tracking isn’t enabled is kind of problematic.

Didn't find what you were looking for?

New post
Was this post helpful?
4 out of 4 found this helpful

Comments

54 comments

  • William - May I ask, when you say "All three began responding after a restart." ..... What is it specifically that you restarted? Have your devices stabilized this week or have they continued to fail on the new firmware?

    For those following along and waiting for updated firmware, I contacted the mysa customer care team this afternoon to inquire about how to get the new firmware. They suggested that it is being rolled out to all and may take another week? I believe "hopefully" was the technical term that they used.

    Seems like a real slow process and screams for some type of user initiated update method in the application? 

    I am slowly getting used to the dismal lack of support and functional software options for these devices :-( 

     

     

     

     

    0
  • I restarted the thermostats themselves, holding the down-arrow control until it said “rt” and went through its usual startup animation. (As an aside, there’s a new animation during the hold period, in which a line of LEDs blinks three times, pauses, and repeats. This is a great improvement over older firmware that left you wondering if the thermostat was still sensing that you were holding down the control.)

    As of today, all 7 are still responsive, and all automations are working smoothly. Firmware version is still 3.10.2.2.

    0
  • Thank you for the updated information and confirmation on the firmware working! I will wait patiently for the updates and hope this corrects things in my environments as well.

    Best regards ….

    0
  • My V1 finally updated to the latest firmware. When I went to re-pair it to HomeKit I’d found it had already done so and was working quite well. It has been stable for at least a week now.

    Well done Mysa!

    0
  • It’s been 2-3 weeks since my last update. In general, the thermostats are still working much better than they were before 3.10.2.2. They’re not super stable, though. Every few days, 1-2 thermostats become unresponsive and need to be rebooted. Five of the seven have been affected so far, some once, some twice. Hopefully the problem is still being worked on.

    0
  • I am also experiencing the same instability that William describes above. There is definitely still an issue in my environment with the devices becoming unresponsive and needing to be reset even after the latest firmware updates. There does seem to be some improvement as to the length of time between resets (with the newest firmware) but there does come a point every few days where these devices still hang up and get lost to HomeKit.

    Hopefully the problem is still being addressed from the original reports as there does still seem to be a problem with the devices and their communications with HomeKit.

    For what it is worth, I have tried additional routers and different isolated protocols with the newest firmware but the problem seems to still exist across several different hardware vendor devices, so I suspect the problem is still in the Mysa communications side of things and not an issue in any specific network device.

     

    0
  • Thanks for the update - this is in-line with that we've been seeing. 

    General improvements and longer periods of stability, but it still drops after a while. We're working on it.

    Just to confirm - did you sign up for our beta testing groups? All of these iterations and setups would be invaluable to us as we pin down a solution. 

    You can sign up here:
    https://getmysa.centercode.com/key/GeneralBetaRegistration

    In short, I can't add much more than what I've said before, but we are listening and have a dedicated team working hard on it. 

    0
  • Yup, I’m signed up for beta! What should I expect…will I be contacted to try new firmware versions? Or does it just enable automatic pushes of new versions out to my thermostats?

    Thanks!

    0
  • So we will be rolling out some testing soon, as we've been building up a sizeable group.

    The general process will be that your firmware will automatically update if you've registered to the testing group with the same email as your Mysa login (I have checked with our product/testing team and you're good to go) and you will receive an email or centercode notification with details and some instructions if we are looking for specific actions etc. 


    0
  • FYI ... I run Homebridge for another automation ecosystem that deploys Hap-NodeJS for finding and publishing HomeKit devices to Alexa. I noticed an interesting coincidence in that when the Mysa devices are working properly with HomeKit, they present themselves over the network and Hap-NodeJS sees them fine and they communicate themselves to Homebridge logs as present and discovered. However, when any of the Mysa devices drop off of HomeKit (as reported within this thread) then they present this error as the connections are also refused to Hap-NodeJS:

    2022-04-20T14:12:42.275Z hapNodeJSClient HAP Discover failed Mysa-d1a6ec -> http://192.168.1.218:57959 error Error: connect ECONNREFUSED 192.168.1.218:57959
        at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1142:16) {
      errno: -61,
      code: 'ECONNREFUSED',
      syscall: 'connect',
      address: '192.168.1.218',
      port: 57959,
      attempts: 5
    }

    I wonder if there would be a way within your firmware coding to simply check for this condition and reset the device to restore communication to normal again? 

    0
  • Hey Dean, 

    Sorry I didn't see this earlier. With the new testing groups and some other changes to our support process we will be phasing out these forums in favour of more direct lines to our team for these kinds of issues. This will take a while, but we are prioritizing bigger, better, and more hands-on dialog to be able to learn and interact with customers experiencing these issues. 

    With that in mind, I encourage you to let the admins of the testing group know about your request, but it also has been logged in our system and anything from this thread has internal eyes on it beyond me. 

    Thanks!

    Thanks!

    0
  • Thanks for the update!

    As an interim (Rube Goldberg - Mousetrap) kinda workaround, I setup a script within Indigo Domotics that resets the problem devices every 6 hours. This seems to work well in keeping them active, so that they are available within the Home App for whenever I beam in to use them.

    Since it is also starting to warm up a bit seasonally, I have high hopes that the mysa team may find a proper solution (to the devices shutting down their IP stack / HAP port communications) within the device firmware before next winter.

    I will keep my fingers crossed.

    0
  • I'm also having daily issues now - at least one or two per day will go "no response" in Homekit

    But they always work in the Mysa app.

    Most of the time a simple reboot of the iPhone or flipping its breaker off/on will set it back online in Homekit

    My setup:

    • 4 x BB-V1-0
    • 2 x v1

    All running 3.12.9.29 firmware

     

     

    0
  • Either a solution was found and I'm not aware of it, or we have been forgotten, but we (V1 proud owners) are still having daily "no response" issues. Any development?

     

    0
  • I still get daily failures in one or more thermostats. They have improved somewhat in that they seem to be better about reconnecting themselves at some point, rather than just staying offline (as far as HomeKit is concerned) until I reboot them.

    0
  • @William Dickson

    By "reconnecting themselves" do you mean that if I wait long enough the device will get out of the "no response" state by itself? 

     

    0
  • Hey everyone!

    Many of the HomeKit issues were solved but seem to be rearing their head again so we're going to investigate further. 

    Just a question: in the past when HomeKit disconnected, did these devices also disconnect in the Mysa app? 

    Passing this along. 

    0
  • @Bradley Pretty

    Indeed, most of the time I'm able to set a new setpoint from the Mysa app (I can see the animation on the thermostat when I'm changing the temp on the app). Also, lately, only a flip of the breaker will set the thermostat back in Homekit. 

    0
  • And with previous HomeKit issues, I just want to clarify that they didn't work in the Mysa app? So when you had an issue there was basically no way to control them? 

    This is strange but at least we can narrow it down. 

    Thanks for the info - I'll let the team know. 

    0
  • @Bradley Pretty

    Hmmm... Although I'm having this issue for at least 2 months (very rarely before that), I can't remember if they were responding within the Mysa app. But the last two times I checked, they were indeed responding in Mysa. Sorry I can't be of much more help. 

    0
  • I have always been able to control the thermostats in the Mysa app. My problems are exclusively with HomeKit control (but note that none of my other many HomeKit devices have a similar problem.

    As for reconnecting, I’ll describe a particular scenario — I mostly use Siri. I might say, “Hey Siri, turn off all the heat.” Sometimes she’ll just confirm that she’s done it. Other times she’ll say, “your thermostats are taking a while to respond.” Then if I do the same command a couple of hours later, it’ll work successfully without error.

    0
  • Thanks for the update - again, all of this is being ticketed for our team to look into and the info helps.

     

    0
  • BTW, I just updated to iOS 16, and Homekit it still having an issue with the same Mysa (showed as "Corridor" above, in iOS 15. Interestingly enough, iOS 16 Home app doesn't show the same device property for the name... "Mysa-270638" in 16, and "Corridor" in 15; this will prove interesting!)

    Here's a pic:

    0
  • I run into these same issues with HomeKit within Home Assistant.

    I'm trying to re-add them to homekit via soft reset, but only one device at a time. I noted something interesting following the below steps.

    1. Connect V2 Baseboard Thermostat to Homekit via soft reset
    2. Wait for it to disconnect from HomeKit
    3. Connect a different Baseboard thermostat (V1) via soft reset
    4. The thermostat in step 1, and step 3 are both visible again without actually doing anything additional with thermostat in step 1

    Seems when you connect an additional device to homekit, the others may reconnect?

     

    0

Please sign in to leave a comment.