Requirements to use the Mysa app

The Mysa app can be installed on many android and apple devices. However, there are some requirements for a device to be able to connect with Mysa.

Android phones and tablets- Phone or tablet running Android 4.4 or later, get the app from the Play Store. 

Apple phones and tablets- Devices running over IOS 10.2, get the Mysa app from the App Store.

Note- Using the Mysa app on an older device that does not meet these requirements will result in incompatibility issues. If you're having issues with the Mysa app make sure your device is up to date. 



Can’t find your answer in our support center? Contact us directly.